راهکار مشکل کار نکردن EasyPHP در ویندوز XP

من قبلا این مشکل رو داشتم که EasyPHP رو روی ویندوز XP نصب میکردم ولی درست استارت نمیشد و کار نمیکرد. متاسفانه از پیام خطا هم اصلا معلوم نبود که علتش چیه. سرانجام با دقت و تحقیق و البته شاید مقداری شانس، علت این موضوع رو فهمیدم و برطرف کردم.

البته باید بگم این موضوع مختص EasyPHP نبود و حتی وقتی بجای EasyPHP از XAMPP استفاده کردم هم همین مشکل وجود داشت، و این نشون میده که مشکل در یکی از اجزاء ای مثل آپاچی یا PHP بوده و نه خود EasyPHP.
راستش از اون زمان مدتی گذشت و من بار دیگر با همین مشکل برخورد کردم، البته یاد داشتم که مشکل مربوط به نصب نبودن runtime کتابخانهء سی++ میکروسافت در ویندوز بود، ولی یادم نبود چه نسخه ای، و این بار نتونستم اون منبع رو که قبلا درش مشخصات این Runtime library رو نوشته بود پیدا کنم.
امروز بصورت تصادفی داشتم هارد کامپیوترم رو بررسی میکردم که یک جایی این کتابخانه رو پیدا کردم! بخاطر همین اون رو اینجا میذارم تا بعدا اگر احتمالا نیاز پیدا کردم در دسترسم باشه، و همچنین این اطلاعات و فایل شاید به درد دیگرانی هم بخوره. البته این داستان یه کم قدیمی شده و ویندوز XP هم آمار استفاده اش پایین اومده، و همچنین در نسخه های جدیدتر EasyPHP شاید این مشکل حل شده باشه، ولی گذاشتن این مطالب بهرحال ضرری نداره شاید روزی کمکی به دیگران یا خودم کرد. تجربیات گذشته رو باید حفظ کرد! گاهی تجربیات و اطلاعاتی از ده ها سال قبل ممکنه به درد کسی بخوره.
خب فایل مورد نظر اینه: vcre(msvcpp2008)dist_x86.exe
نترسید توش ویروس و برنامهء هک نیست :D
راستش انگار زیاد به میکروسافت نمیشه اعتبار کرد چون تازگی میخواستم یک فایل پشتیبانی مربوط به ویندوز XP رو از سایت میکروسافت بگیرم که دیدم ظاهرا حذف شده، که احتمالا بخاطر خاتمهء پشتیبانی از ویندوز XP توسط میکروسافت باشه، و هر چقدر هم که گشتم متاسفانه اون فایل رو جایی پیدا نکردم!

3 دیدگاه در “راهکار مشکل کار نکردن EasyPHP در ویندوز XP

    • همون ویندوز ایکس پی کار ما رو راه میندازه اکثرا دلیل و انگیزه و نیاز مهمی برای آپگرید نداشتم تا حالا. البته سخت افزار هم قدیمی و ضعیف هست طبیعتا یکی از دلایله. اونایی ویندوز رو زود آپگرید میکنن که معمولا سخت افزارشون رو هم کم و بیش بروز نگه میدارن، بعدم نرم افزارهای متنوع و جدیدی استفاده میکنن که بعضیاشون به سیستم عامل های جدیدتری نیاز دارن، بخصوص نرم افزارهای سنگین و گرافیکی، مثل ویژوال استودیو، مجازی سازها، بازیها، اتوکد، فتوشاپ آخرین نسخه و این حرفها. ولی منکه اینطور نرم افزارها نیاز مبرمی نداشتم و بعضا هم با نسخه های قدیمی ترشون کار میکنم نیازهای زیاد و خیلی حرفه ای ندارم که نسخه های قدیمی جواب ندن. البته یک دلیلی که اکثریت ملت ما از نرم افزارهای بروز استفاده میکنن بخاطر اینه که قانون کپی رایت توی ایران رعایت نمیشه و مجبور نیستن واسه هر نرم افزار جدید خداد تومن پول بدن، وگرنه خیلی از آپگریدها اساسا ضرورت چندانی ندارن.

پاسخ دهید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *

*

شما می‌توانید از این دستورات HTML استفاده کنید: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>